Installation of latest owncloud client on Linux Mint 18

Here is a quick install for the latest version of the owncloud client on Linux Mint 18:

 

 

The “Depends: ocqt562-libqt5gui5 but it is not going to be installed” problem

Many people report issues similar to this here:

It is a know issue and has been discussed in the owncloud client github issues extensively: https://github.com/owncloud/client/issues/6034. It mostly boils down to either an old repo url the /etc/apt/sources.list.d/owncloud-client.list, a faulty prior installation or a combintation of both.

What can you do? Make sure you have only one line in your /etc/apt/sources.list.d/owncloud-client.list. It must look like this

After you made sure of that, remove whatever parts left of your previous owncloud client and give it a fresh install.

And if it still does not work? Hit the owncloud github and report it as a new issue: https://github.com/owncloud/client/issues

(186 Posts)

20 years of coding and working as software engineer but I am still eager to learn more. I am very passionate when it comes to open source, Linux and Java. But I made my peace with Windows long ago to fully enjoy my PC gaming hobby. I have a soft spot for 90s electronic music and Babylon 5. In the evenings you will find me roaming the endless space in Warframe (IGN k05h).

5 thoughts on “Installation of latest owncloud client on Linux Mint 18

  1. Volker

    Die Installation funktioniert leider nicht (Linux Mint 18.3), folgender Fehler erscheint beim Installieren (letzter Befehl):
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    owncloud-client : Hängt ab von: libowncloudsync0 (= 2.4.1-9083) soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5core5a soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5dbus5 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5gui5 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5keychain1 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5network5 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5webkit5 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5widgets5 soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5xml5 soll aber nicht installiert werden
    Hängt ab von: owncloud-client-l10n soll aber nicht installiert werden
    Hängt ab von: ocqt562+240-libqt5sql5-sqlite soll aber nicht installiert werden
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

    Wie kann ich das beheben? Vielen Dank!

    Reply
    1. Marcel

      Hallo Volker.,
      ich suche seit einiger Zeit nach einer Lösung für das von Dir beschriebene Problem.
      Hast Du inzwischen eine Lösung dafür gefunden?

      Reply
    2. Lars Händler

      @Volker, @Marcel you are not alone with you issues. I updated the blog post because I got a number of similar questions over the past months. Hope that helps.

      Reply
  2. ElliotElep

    I found this post very useful. Thank you. Inspired by this, and being on Linux Mint LMDE2, I have applied this :

    $ sudo sh -c “echo ‘deb http://ftp.debian.org/debian jessie-backports main’ >> /etc/apt/sources.list.d/additional-repositories.list”
    $ sudo apt-get -t jessie-backports install owncloud-client

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.