Unable to require openssl, install OpenSSL and rebuild ruby … on Ubuntu 14 LTS

I followed the steps from http://rubyonrails.org/download/ to install ruby but ran into this error:

That’s what I did:

The next thing would be installing rails with

But this returned the mentioned error:

From my google search I gained that this is a rather common error but none of the suggested solutions helped out of the box for my Ubuntu 14 LTS. The most important thing was installing the correct openssl devel package and not only openssl:

While on it I also installed some other packages that threw errors in the prior make process

To get the ruby installation recognize everything that has been installed by the latest apt-get install best clean up before you do a second round of configure-make-voodoo:

Now you can install rails without any trouble:

3 People think it's helpful 😀

3 Comments Unable to require openssl, install OpenSSL and rebuild ruby … on Ubuntu 14 LTS

  1. Pingback: « Unable to require openssl, install OpenSSL and rebuild ruby » | Sois Net !

Leave a Reply

Your email address will not be published. Required fields are marked *